当前位置:首页 > 问答

通达信不含未来函数指标公式

我来帮TA回答

通达信自带的交易系统公式哪些不含有未来函数

您好,通达信自带的交易系统公式均不含未来函数。

通达信公式没有未来函数,前几天的信号怎么会消失

问题出在“REFDATE(低,DATE);”,
REFDAY()函数的第二个参数必须是常数,而DATE却是个变量,于是就强制把DATE变为常量,返回DATE的最新值,对于几天前而言,DATE的最新值就是未来数据,于是就产生了引用未来数据的情况。
简而言之,应用了未来数据。
把它改为不应用未来数据的公式,如下:
N:=90;M:=3;
低:REF(LLV(L,N),M);
XG:低=L AND ((C-L)>(O-C) OR (O-L)>(C-O)) ,COLORYELLOW,LINETHICK5,STICK;

通达信庄家抄底王指标公式含未来函数吗

{把原来公式中的未来函数去掉,就木有“未来函数”了}


周期:=15;

过滤:=8;

选股1:=-26;

抄底:=-40;

庄家抄底王:0,COLORFF00FF,POINTDOT;

VAR2:=MA(CLOSE,5);

VAR3:=MA(CLOSE,10);

VAR4:=MA(CLOSE,20);

VAR5:=MA(CLOSE,30);

VAR6:=(VAR2+VAR3+VAR4+VAR5)/(4);

VAR7:=((VAR6-REF(VAR6,周期))/(REF(VAR6,周期)))*(100);

VAR8:=((VAR6-REF(VAR6,周期))/(REF(VAR6,周期)))*(100);

VAR9:=EMA(VAR7,过滤);

{红包:IF((TROUGHBARS(3,15,1)=0) AND (HIGH>LOW+0.01),10,(-5)),COLOR00FF00};

反转:STICKLINE(VAR9>1*REF(VAR9, 1), VAR7, 0, 2.5, 0), COLOREE00EE;

持股:STICKLINE(VAR7>1*REF(VAR7, 1), VAR7, VAR9, 2.5, 0), COLORRED;

持币:STICKLINE(VAR7<1*REF(VAR7, 1), VAR7, VAR9, 2.5, 1), COLORGREEN;

洗盘:STICKLINE(VAR7<1*REF(VAR7, 1) AND VAR9>1*REF(VAR9, 1), VAR7, VAR9,2.5, 0), COLOR00EEFF;

VAR10:=((CLOSE-MA(CLOSE,58))/(MA(CLOSE,58)))*(100);

VAR11:=((VAR10>(1)*(REF(VAR10,1))) AND (VAR10<选股1) AND (VAR10>抄底))*(1.5);

VAR12:=((VOL)/(CAPITAL))*(100);

VAR13:=LLVBARS(LOW,50);

VAR14:=SUM(VOL,VAR13);

VAR15:=HHVBARS(HIGH,50);

VAR16:=SUM(VOL,VAR15);

VAR17:=((CLOSE-REF(OPEN,VAR15))/(REF(OPEN,VAR15)))*(100);

VAR18:=((VAR16)/(CAPITAL))*(100);

VAR19:=((CLOSE-REF(OPEN,VAR13))/(REF(OPEN,VAR13)))*(100);

VAR20:=((VAR14)/(CAPITAL))*(100);

VAR21:=MA(CLOSE,3);

VAR22:=(REF(CLOSE,2))*(0.86500001);

VAR23:=(REF(CLOSE,13))*(0.77200001);

VAR24:=MIN(VAR22,VAR23);

VAR25:=MA(CLOSE,13);

抄底王:(IF(((CLOSE-VAR24)/(CLOSE)<0.02999999) AND (VAR17<(-35)) AND ((SUM(VAR12,5))/(5)<1.8),1,0))*(10),COLORFFFFFF;

DRAWTEXT(抄底王, 抄底王, ' 成功率90追 '), COLORFFAA00;

VAR26:=((CLOSE-REF(CLOSE,1))/(REF(CLOSE,1)))*(100);

VAR27:=(EMA(CLOSE,12)-EMA(CLOSE,26))*(100);

VAR28:=EMA(VAR27,9);

VAR29:=(2)*(VAR27-VAR28);

DRAWTEXT(VAR27<(-50) AND VAR26>7 AND VAR27<VAR28, (-10), '底'), COLORWHITE;

DRAWTEXT(VAR27<(-50) AND VAR26>7 AND VAR27>=VAR28, 5, '追'), COLORWHITE;

STICKLINE(VAR27<(-50) AND VAR26>7, 0,(-10), 2.5, 0), COLORFFFF66;

通达信指标公式源码用软件检测是没有未来函数的,怎么到了软件上就显示有未来函数了呢?如何正确判断?

对未来函数的判定标准是不同的,有些未来函数对信号影响不大

你的一个关于通达信主力吸筹的回答,你的回答引用了一个“上帝指纹”的指标,请问这个指标方便提供吗?

你是股市新人,想做好,得不到方法。这样的公式好几种,计算方式都是均线与当时股价差值,类似于乘率指标。那里有可以看到主力吸筹的能力。主力是否吸筹,要看资...

要编个主力吸筹的公式,哪位专家给个逻辑建议?

说实话没有什么好的建议,因为要想分析这个,只靠价格,成交额,成交量,这些基础数据基本无法做到.因为换角度思考,吸筹就是应该隐蔽,也就是在我买进股票的同时,对行情造成的影响越小越好.这样就没人发现了.等让大家都看到行情变化了,那就一定是拉升出货了.
而且不同人的性格决定了他不同的分析思路,和操盘手法,所以这个很难,找到规律,也就无法做成公式指标.